019635

このフォームからは投稿できません。
name
e-mail
url
subject
comment
JA2GRC-開発室




◆ JTLinkerでのメッセージ 投稿者:  引用する 
くま ●下記と全く同様な現象が生じてしまいました。
今朝までは、正常に動作していました。JT65-HFで正常に動作しているので、HB9HQXも動作させようとし、HB9HQXを取り込む動作途中で、おかしくなったようです。
動作環境:Windows10
申しわけありませんが、ご教示お願いいたします。

jt_Linker Ver 2013.12.19について。
jt_linkerを起動すると、データーベースから取り込めませんとでて、エラー、処理 Get HQX
発生 System.Data.Sqliteなどと下にいろいろと表示されます一度ご指導願います。
2013/12/20(金) 09:47 | URL | 菰方昭彦(JH2IZA) #EBUSheBA[編集]
2017/09/07(Thu) 17:10:16 [ No.513 ]
◇ Re: JTLinkerでのメッセージ 投稿者:Taka(JA2GRC)・管理者  引用する 
ねずみ おじさんハムさん

HB9HQXで上手くリンクできないのは、以下の原因が考えられます。

・HB9HQXのログ用データベースが一度も作られていない。
・ログファイルを指定するフォルダの設定が違っている。
・HB9HQXのログ用データベースのタイトル名とJT_Linkerの設定値が合っていない。
・HB9HQXのログデータベースが壊れている。

この辺りを調べて下さい。
2017/09/07(Thu) 21:36:21 [ No.514 ]
◇ Re: JTLinkerでのメッセージ 投稿者:  引用する 
くま Taka(JA2GRC)さん、

早速のご返事ありがとうございます。
今朝までは、JT65-HFでの動作は確実でした。
HB9HQXとつながらず、それはリンクファイル名の間違い(途中にスペースがあるのに気がつかなかった)でした。
ところが、操作中にどこからか?、HB9HQX(セットせず)にはもちろん、JT65-HFのみでも接続できなくなったのです。

SetUpができなくなり(JT65-HFはロードして正常に動作しています)、Setupが動作不能の状態です。Saveをすると、次のメッセージが出て、データベースから取り込めません。

例外NO5
HQXログデータベースから取り込めません。一度もHQXログファイルが作成されてないか、HQXログファイルが壊れています。HQXログファイルを一旦削除した後、ログを作成してから再試行してください。
エラーの詳細は以下の通りです。
処理:GetHQX
発生:System。Data.SQLite
・・・・・
・・・・・
OKをクリックしても、すぐ同じメッセージが繰替えされます。


念のため、最初にJTLinkerをダウンロードする前の日付まで戻って、システム再現したのですが、結果は同じです。
これはWindows10でのことですが、もう1台のXPでは、まったく正常です。

本当に申し訳ありません。朝から、この状態でパソコンにらめっこで、かみさんが諦め顔で、早く飯を食え!と言っています。よろしくお願いいたします。
 72歳のおじさんハム

2017/09/07(Thu) 22:53:02 [ No.515 ]
◇ Re: JTLinkerでのメッセージ 投稿者:Taka(JA2GRC)・管理者  引用する 
ねずみ おじさんハムさん

一旦、初期化するのがよいと思います。

・JT_Linker.iniと言うファイルを削除して下さい。(適当な名前にリネームすれば、削除&バックアップになって良いと思います)
・JT_Linkerを起動して下さい。 何にもリンクされない状態で起動したら、正解です。
・後は、通常のリンク設定をして下さい。

・HB9HQXとリンクする時におかしくなるようだったら、一度、HB9HQXのログも初期化(削除してから新たに作る)してみて下さい。

以上、ご健闘を祈ります。
2017/09/07(Thu) 23:09:52 [ No.516 ]
◇ Re: JTLinkerでのメッセージ 投稿者:  引用する 
くま Taka(JA2GRC)さん

解決できました。
JT65-HF、JT65-HB9HQX のどちらからも、使用可能になりました。
結局のところ、何らかの操作で不具合が生じるようになってから、何度、再インストールしても、
C:\Users\ユーザー名\AppData\Local\JA2GRC\JT_Linker
が、残存していて、いたずらをしていたようです。

・JT_Linker.iniと言うファイルを削除して下さい。

のアドバイスが役に立ちました。これがあることは、全く知りませんでした。

昨夜、午前2時までの奮闘が実りました。
重ねて、適切なご教示をいただき、深く感謝いたします。

迷い解けたスッキリ おじさんハムより
2017/09/08(Fri) 07:20:51 [ No.517 ]
◇ Re: JTLinkerでのメッセージ 投稿者:Taka(JA2GRC)・管理者  引用する 
ねずみ 上手く行ったようで、良かったです。
2017/09/08(Fri) 19:46:25 [ No.518 ]

◆ Win7でもインデックスおよびのエラー 投稿者:  引用する 
くま Linkerを立ちあげると「インデックスおよび長さは文字列内の場所を参照・・・ パラメータ名:length」のエラーメッセージが表示されます。
続行のボタンを押してもDate窓に//、Time窓には:Uが表示されTestボタンも効きません。
WSJT-XとJTDXにはLinkしています。
この状態ではHamlogにデータが送られずQSOもままなりません。
よろしくお願いします
2017/05/06(Sat) 22:26:24 [ No.487 ]
◇ Re: Win7でもインデックスおよびのエラー 投稿者:Taka(JA2GRC)・管理者  引用する 
ねずみ JO3TAP/坂田さん

今までの状況の続きなのでしょうか? 一旦上手く行って、またおかしくなったのでしょうか?

・状況を単純化する為に、何処までが上手く行ってどこからがおかしくなったか?を明確にした方がよいのではないでしょうか。

また、同じく現象を単純化する為に、
・JT_Linker.iniを削除して初期化した状態。
・複数リンクせずに単一のアプリだけリンクした状態で試す。
・他のアプリを動かさずに動作させる。
などを試してみて、何処までが上手く行って、どこからおかしくなるかを確認するのが良いのではないかと思います。
2017/05/07(Sun) 10:58:59 [ No.488 ]
◇ Re: Win7でもインデックスおよびのエラー 投稿者:  引用する 
くま なぜか解決しました。
メインPCからハムログデータとwsjtx_jog.adiをコピーして置き換えたところ、立ち上がりと窓のエラー表示が解消しました。
ご指摘いただいた確認方法は今後の備えにさせていただきます。
ありがとうございました。
2017/05/07(Sun) 11:12:13 [ No.489 ]
◇ Re: Win7でもインデックスおよび・・のエラー 投稿者:  引用する 
くま 2週間ほど前から再びエラー表示が現れました。
多分JTDXをバージョンアップしたせいだと思われます。
今回は、OSをWin10に戻しアップデード、その後以下のソフトをセットアップしたところほぼ正常に戻りました。
NewModeのFT8も支障ないようです。

Hmalog:Ver5.26c
WSJT-X:v1.8.0-rc1
JT AlertX:v2.10.0
JT Linker:Ver2016.10.26a

更にJTDXv17.9とJT AlertX2.10.0を追加したところ、
JTDXではバンド表示の窓の左、グリーンの丸マークの中に「S」が出現?、送信時にはQRG表示の窓の背景色がグレーからレッドに変わり、ブルーの周波数表示が0.000000になります。
ローカル局にモニターしてもらったところ交信はできました。
JT Linkerもハムログにデータを送ります。
当分はWSJT-Xで運用することにしてこのまま様子を見ます。
2017/07/22(Sat) 11:36:02 [ No.495 ]
◇ Re: Win7でもインデックスおよびのエラー 投稿者:Taka(JA2GRC)・管理者  引用する 
ねずみ JO3TAP/坂田さん

我が家でも同じ環境で試してみましたが、JTDX、WSJT-X、JT-Alert、Hamlog、JT_Linkerともに問題なく動作しています。

状況が良く分かりませんが、QRG関連の表示がおかしくなるのは、もしかしてCAT関連の問題ではないでしょうか?
2017/07/22(Sat) 14:59:34 [ No.496 ]
◇ Re: Win7でもインデックスおよびのエラー 投稿者:  引用する 
くま たびたびで恐縮です
今朝立ちあげるとNo487の状態になり、iniを削除して再インストールしても復帰しません。
JT65-HF HB9HQX4.9.6をインストールしたときは正常でした。
デスクトップPCでは問題なく動くので、これは使うパソコンとの相性のせいと諦めるしかないのでしょうか。
2017/07/29(Sat) 11:22:07 [ No.502 ]
◇ Re: Win7でもインデックスおよびのエラー 投稿者:Taka(JA2GRC)・管理者  引用する 
ねずみ JO3TAP/坂田さん

・状況を単純化する為、個別にチェックしていただけませんでしょうか?

・現在問題が起こっているのは、どのアプリとリンクした時なのでしょうか?

・問題の状況が起こるのは、リンクしているアプリのリンク先が違っているか、リンク先のログファイルが壊れているかのどちらかです。

・初期化して立ち上げた時に、どのアプリともリンクされていない状況になっていますでしょうか?

・ちなみに、JT_Linker.iniを削除すれば、再インストールは必要有りませんので、そのまま再起動して下さい。
その状態では、どのアプリともLinkされていない状態になっています。
2017/07/30(Sun) 11:16:23 [ No.503 ]
◇ Re: Win7でもインデックスおよびのエラー 投稿者:  引用する 
くま 1.JTDX.WSJT-X,HB9HQX-Ed.とも続行のボタンを押せばLink の表示はでますが、症状は同じです。
 ハムログにデータが転送されません。
2.リンク先のファイルについて
 メインPCのハムログからバックアップをコピーしてノー トのハムログでリストア。
 C:Hamlog\LogList.adiを出力
 HB9ーEdにはこのままImport
 WSJT-X,JTDXには、wsjtx_log.adiにリネームしてコ   ピー・置き換え
これで交信データが統一されていると思います。
この間で不具合が生じるのでしょうか。
2017/07/31(Mon) 17:13:42 [ No.504 ]
◇ Re: Win7でもインデックスおよびのエラー 投稿者:Taka(JA2GRC)・管理者  引用する 
ねずみ JO3TAP/坂田さん

1.初期状態でリンクが取れているのでしょうか?
  もしそうならルートフォルダ(C:\)にログファイルが出来ちゃっていませんでしょうか。
  初期化状態ではいずれのアプリのリンクもルートフォルダ(C:\)を指しています。
2.Hamlogのバックアップとは何でしょうか? 余り関係ないと思います。
  Hamlogのファイルをコピーしているのでしょうか? ちょっと意味不明です。
  各アプリで受信した局のログを使われないのでしょうか?
2017/07/31(Mon) 19:22:48 [ No.505 ]
◇ Re: Win7でもインデックスおよびエラー 投稿者:  引用する 
くま この掲示板ではいつもお手数をおかけし恐縮です。
WSJT-X、JTLinker、JTAlertXのINIとアプリを全て削除し、再セットアップしてみました。
デフォルトの状態ではハムログにデータが転送されましたが、WSJT-Xのwsjtx_log.adiを触るとエラーメッセージが表示されるので、ポイントはこのあたりだと思われます。
その後、eQSLからログをダウンロードしてこのファイルに貼り付けて見ました。
今のところCQのデコードラインもほぼログどおりにカラー表示されるようになりました。
2017/08/05(Sat) 15:25:02 [ No.509 ]
◇ Re: Win7でもインデックスおよびのエラー 投稿者:Taka(JA2GRC)・管理者  引用する 
ねずみ JO3TAP/坂田さん

長くの間、問題点を提示されていますが、
「WSJT-Xのwsjtx_log.adiを触るとエラーメッセージが表示される」
これについて、どのように触られて居られるのか提示されないと、何とも判断のしようがありません。
2017/08/05(Sat) 19:31:32 [ No.510 ]
◇ Re: Win7でもインデックスおよびのエラー 投稿者:  引用する 
くま このたびの不具合の原因と思われるのは以下のとおりです。
1.WSJT-Xを新規インストールして、1交信行いwsjtx_log.adiを作成
2.ハムログからLogList.adiを出力して1.のファイル名に変更
3.2.をコピーして1.と置き換えたところでJTLinkerのエラー発生
ファイルを1.に戻すと正常にデータがハムログに転送されました。
デスクトップPCではこの方法でうまくいっていたので安心していましたが、手元のノートPCではNGでした。
2017/08/06(Sun) 19:15:53 [ No.511 ]
◇ Re: Win7でもインデックスおよびのエラー 投稿者:Taka(JA2GRC)・管理者  引用する 
ねずみ JO3TAP/坂田さん

そうなんですか、てっきり、wsjt-xのログファイルをそのまま使っているのだと思っていました。

ログファイルを操作される場合に付いては、私の方では検証していませんので、問題発生した場合は自己解決していただく以外方法はありません。

前に上手く行ったのは、たまたま上手く行ったのだと思います。
2017/08/06(Sun) 21:17:43 [ No.512 ]

◆ JT_Linker がスタックすることがあります。 投稿者:  引用する 
くま JT65-HF HB9HQX 4.9.6 関連で対策があればお知らせ頂くと幸いです。
JT_Linker がスタックする条件があることが判りました。
DXデータを保存しようした時に発生しています。

エンティティサーチタイムアウトです。
エンティティを選択して再送して下さい。 と表示されOK釦を押下して
エンティティを再表示して選択後ハムログに保存します。

ここ迄は、正常処理していましたが、その後のQSOの登録で問題がありです。

この状態のとき JT_Linker がスタックしているようで、この時に登録すると

ログに登録されずに、Station(赤表示)、Grid(赤表示)になりました。
対策としては、JT_Linker を再起動しています。
再起動させないないで済む方法が有りましたらお知らせ頂くと幸いです。
佐倉市 JA1KWB 市東
2017/08/01(Tue) 18:34:07 [ No.506 ]
◇ Re: JT_Linker がスタックすることがあります。 投稿者:Taka(JA2GRC)・管理者  引用する 
ねずみ JA1KWB/市東さん

レポートありがとうございます。 調べてみます。

当面の回避策は、エンティティサーチのタイムアウトを長く設定して、タイムアウトを発生しにくくすれば、問題の発生頻度は下がると思います。

初期値ではエンティティサーチのタイムアウトは10秒に設定してあります。 これを、ご自身がエンティティ選択する余裕有る時間に設定するのがよいと思います。
2017/08/02(Wed) 09:41:23 [ No.507 ]
◇ Re: JT_Linker がスタックすることがあります。 投稿者:  引用する 
くま JA2GRC/大塚様

早速の情報を有り難う御座いました。
エンティティ選択する時間を、余裕有る時間に変更して様子を見ることにします。

佐倉市 JA1KWB 市東
2017/08/02(Wed) 11:44:19 [ No.508 ]

◆ QTHに空白が入る 投稿者:jh4vaj   HomePage    引用する 
ねこ WSJT-Xとの連携で使わせてもらっています。

QTHにチェックを入れて転送させています。
DX局は国名が入ります。←これは期待通り。

JA局は空白が入ります。
「空」ではなく、「空白」という文字が入ります。
正しくは「空白」ではないのかもしれませんが、
見た目では空白が一文字入ったように見えます。

実害はないのですが、手動で入力する際に、
頭に空白があるのはちょっと気持ち悪いので
いつも消してから入力しています。

いつか何かのついでにでも確認して
もらえるとありがたいです。

よろしくお願いします。

2017/07/24(Mon) 19:02:11 [ No.498 ]
◇ Re: QTHに空白が入る 投稿者:Taka(JA2GRC)・管理者  引用する 
ねずみ JH4VAJさん

ご指摘ありがとうございます。

QTHには国外局の場合はエンティティサーチの結果、国内局の場合はHamlogユーザーリスト等のHamlog側のQTH検索結果が入るようになっています。

諸々の事情で、QTHデータが何もない時は" "(スペース)を入れています。

この部分については、色々遍歴があって、現在の形に落ち着いています。 今後、上手い方法が見つかれば変更になる可能性があります。 その時には、ご指摘の部分、ご希望の通りになるのではないかと思います。
2017/07/25(Tue) 09:14:34 [ No.499 ]
◇ Re: QTHに空白が入る 投稿者:jh4vaj   HomePage    引用する 
ねこ ご回答頂き、ありがとうございます。
仕様だったのですね。
最近使い始めたもので、経緯を知らず、失礼しました。

では改めて、設定で空白を入れるか入れないかを
選択できるようにしていただけないでしょうか?

強い要望ではありません。
何かのついでにご検討いただけるとうれしいです。

よろしくお願いします。
2017/07/25(Tue) 19:17:31 [ No.500 ]
◇ Re: QTHに空白が入る 投稿者:Taka(JA2GRC)・管理者  引用する 
ねずみ JH4VAJさん

頭に入れておきます。
2017/07/25(Tue) 20:04:57 [ No.501 ]

◆ JT65とLinkerのリンク 投稿者:  引用する 
くま JA2GRC 大塚OM殿
   JA3HWL喜多です
お世話になっております。
JT-Linkerについてお尋ねします
ある時期まで正常に動作し便利に使用させていただいておりましたが急にLinkerがリンクしなくなりました、原因がよく解りません。何かヒントがあれば御教示ください。
環境:PC: Windous7 SP1
NET Framework315
JT: Ver 4096
  Linker: Ver 2016-10-26a
症状:JT65にリンクせず setupのボタンがきかず、固まる(set upの内藤が確認できない)Linker よりROGには正常に転送する。JT-65で疑似的にデ-タ-を作成してもLinkerに転送しない→JT65とLinker のやり取りがNGとおもわれます。PCも自分なりに確認しましたが?
※JT-65、Linker 共いくら再インスト-ルしてもNG
当初快適に動作しておりましたので、不具合になる心あたりもなく、全く分からない状態です、お忙しいところお手数ですが御教示よろしくお願いいたします
2017/07/19(Wed) 19:49:29 [ No.493 ]
◇ Re: JT65とLinkerのリンク 投稿者:Taka(JA2GRC)・管理者  引用する 
ねずみ JA3HWL/喜多さん

・変化した時に何があったか分かれば良いのですが。
 プログラムのバージョンアップとか。

・取り敢えず、初期値に戻すには、JT_Linker.iniを削除してからJT_Linker.exeを起動して下さい。
 これで、初期状態で起動します。
 再インストールを何度やっても、JT_Linker.iniが残っている限り、同じ設定で起動します。

・頂いた情報から判断できるのはこれぐらいですかね。
2017/07/19(Wed) 21:08:15 [ No.494 ]
◇ Re: JT65とLinkerのリンク 投稿者:  引用する 
くま JA3HWL喜多です。
OMのご指導でJT関係のソフトをすべて削除して、再度インスト-ルするもNG

最終理由はよくわかりませんが、PCのリカバリ-を実施したところ正常になりました。
お手数おかけいたしました
今後もよろしくお願いいたします。
2017/07/23(Sun) 10:21:22 [ No.497 ]

Page: | 1 | 2 | 3 | 4 | 5 |

投稿者 No. 削除キー

- YY-BOARD - icon:MakiMaki
- Antispam Version -